summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2017-02-23 12:40:01 +0100
committerPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2017-02-25 16:27:04 +0530
commit58a376a080c80698a6c243b1dfe948c60ae16ac2 (patch)
tree95f5c72f36a934fae85fe3ebf6612d4d7c695a22 /Makefile.am
parentceb5a8a96becee3d3d5df9a51428e629d66d0585 (diff)
build: pass "--with systemd" to rpmbuild if needed
In case ./configure detects that the environment is using systemd, the "make install" step will copy the gluster-block.service file to the right location. However, the RPMs do not include this file by default, so adding a "--with systemd" to rpmbuild/mock is needed (until there is some form of auto-detection in the .spec). Change-Id: Id64fa664f5b2a3d3c4675b2ad7a54d415a54281a Signed-off-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 60c14d4..90d12ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,9 +8,14 @@ CLEANFILES = *~ gluster-block.spec
EXTRA_DIST = autogen.sh README.md COPYING-GPLV2 COPYING-LGPLV3
+if USE_SYSTEMD
+RPM_WITH_FLAGS = --with systemd
+endif
+
rpms: prep
rpmbuild --define '_topdir $(abs_top_builddir)/build/rpmbuild' \
--define '_sourcedir $(abs_top_builddir)' \
+ $(RPM_WITH_FLAGS) \
-ba gluster-block.spec
srpm: prep