summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJi-Hyeon Gim <potatogim@gluesys.com>2017-09-09 13:35:25 +0900
committerJi-Hyeon Gim <potatogim@potatogim.net>2017-09-21 19:30:27 +0900
commitfeb517ae133fd4af0dc35725070e80522ea43539 (patch)
tree51aa21a538139b495de5cb2a0b60daa94f086654 /Makefile.am
parent95db5c36b38fa883141cb3eeb237957d18091168 (diff)
dist: supports initd for non-systemd distros
Problem gluster-blockd supports systemd officially but many legacy distros want to use initd Resolve includes initd scripts for non-systemd distros Change-Id: I8495e8d9abbef6d26ac7dc8dbbe6d07e7713f537 Signed-off-by: Ji-Hyeon Gim <potatogim@gluesys.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e5018b..962da8c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,8 @@ EXTRA_DIST = autogen.sh README.md COPYING-GPLV2 COPYING-LGPLV3 \
if USE_SYSTEMD
RPM_WITH_FLAGS = --with systemd
+else
+RPM_WITH_FLAGS = --with initd
endif
rpms: prep