summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXiubo Li <lixiubo@cmss.chinamobile.com>2018-01-03 02:52:46 -0500
committerXiubo Li <lixiubo@cmss.chinamobile.com>2018-01-03 03:03:47 -0500
commit5d98272c53816813872aaa807e4ccc1ee2ad1bfc (patch)
tree3e501a18dce7e6a15e12939f79a700d91feb30bc /configure.ac
parentf03d6410625c2a606904e8bafb7096181ea9b5a0 (diff)
configure: fix compiling error for lacking of AM_PROG_CC_C_O in configure.ac
Added the AM_PROG_CC_C_O macro although it is obsolete since automake 1.14. But as automake < 1.14 is still out there. Change-Id: Id6e0db318068a65c6cb9c2bfb0c32af4eb4a9b70 Signed-off-by: Xiubo Li <lixiubo@cmss.chinamobile.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3fd3646..8b8107d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,9 @@ LT_INIT
# Checks for programs.
AC_PROG_CC
+# For legacy reasons.
+AM_PROG_CC_C_O
+
AC_CHECK_PROG(RPCGEN, rpcgen, yes, no)
if test "x$RPCGEN" = "xno"; then
AC_MSG_ERROR([rpcgen not found, needed for building])