summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2017-02-15 15:20:22 +0530
committerPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2017-02-15 15:20:22 +0530
commit86ae67f117bc2a8c385144065c01e63027248a50 (patch)
tree9caa52468a2ad6ea1a79e1626c4bb439200e1f52 /daemon/Makefile.am
parent8eaecd2b99e686dbf6acd401b55f04220f3149d0 (diff)
gluster-blockd: create logging directories
Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 1e018a8..038fce8 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -2,9 +2,11 @@ sbin_PROGRAMS = gluster-blockd
gluster_blockd_SOURCES = gluster-blockd.c
-gluster_blockd_CFLAGS = -I$(top_srcdir)/utils/ -I$(top_srcdir)/rpc
+gluster_blockd_CFLAGS = -DDATADIR=\"$(localstatedir)\" \
+ -I$(top_srcdir)/utils/ -I$(top_srcdir)/rpc
-gluster_blockd_LDADD = $(PTHREAD) $(top_srcdir)/rpc/libgbxdr.la $(top_srcdir)/utils/libgb.la
+gluster_blockd_LDADD = $(PTHREAD) $(top_srcdir)/rpc/libgbxdr.la \
+ $(top_srcdir)/utils/libgb.la
DISTCLEANFILES = Makefile.in