summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2285c29..9644f7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,17 @@ AC_CHECK_LIB([pthread], [pthread_mutex_init],[PTHREAD="-lpthread"],
AC_MSG_ERROR([Posix threads library is required to build gluster-block]))
AC_SUBST(PTHREAD)
+AC_CHECK_PROG(TCMURUNNER, tcmu-runner, yes, no)
+if test "x$TCMURUNNER" = "xno"; then
+ AC_MSG_ERROR([tcmu-runner not found; try again after installing])
+fi
+
+# FIXME: version check, need atleast 'targetcli-2.1.fb43'
+AC_CHECK_PROG(TARGETCLI, targetcli, yes, no)
+if test "x$TARGETCLI" = "xno"; then
+ AC_MSG_ERROR([targetcli not found; try again after installing])
+fi
+
# Dirty hacky stuff to make STATEDIR work
if test "x$prefix" = xNONE; then
test $localstatedir = '${prefix}/var' && localstatedir=$ac_default_prefix/var