summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 038fce8..faacb67 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -3,10 +3,11 @@ sbin_PROGRAMS = gluster-blockd
gluster_blockd_SOURCES = gluster-blockd.c
gluster_blockd_CFLAGS = -DDATADIR=\"$(localstatedir)\" \
- -I$(top_srcdir)/utils/ -I$(top_srcdir)/rpc
+ -I$(top_srcdir)/utils/ -I$(top_srcdir)/rpc \
+ -I$(top_builddir)/rpc/rpcl
-gluster_blockd_LDADD = $(PTHREAD) $(top_srcdir)/rpc/libgbxdr.la \
- $(top_srcdir)/utils/libgb.la
+gluster_blockd_LDADD = $(PTHREAD) $(top_builddir)/rpc/libgbrpc.la \
+ $(top_builddir)/utils/libgb.la
DISTCLEANFILES = Makefile.in