summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 1e018a8..038fce8 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -2,9 +2,11 @@ sbin_PROGRAMS = gluster-blockd
gluster_blockd_SOURCES = gluster-blockd.c
-gluster_blockd_CFLAGS = -I$(top_srcdir)/utils/ -I$(top_srcdir)/rpc
+gluster_blockd_CFLAGS = -DDATADIR=\"$(localstatedir)\" \
+ -I$(top_srcdir)/utils/ -I$(top_srcdir)/rpc
-gluster_blockd_LDADD = $(PTHREAD) $(top_srcdir)/rpc/libgbxdr.la $(top_srcdir)/utils/libgb.la
+gluster_blockd_LDADD = $(PTHREAD) $(top_srcdir)/rpc/libgbxdr.la \
+ $(top_srcdir)/utils/libgb.la
DISTCLEANFILES = Makefile.in