summaryrefslogtreecommitdiffstats
path: root/rpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rpc/Makefile.am')
-rw-r--r--rpc/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/rpc/Makefile.am b/rpc/Makefile.am
new file mode 100644
index 0000000..20ed49d
--- /dev/null
+++ b/rpc/Makefile.am
@@ -0,0 +1,15 @@
+noinst_LTLIBRARIES = libgbxdr.la
+
+libgbxdr_la_SOURCES = block_clnt.c block_xdr.c block_svc.c block_svc_routines.c glfs-operations.c
+
+noinst_HEADERS = block.h glfs-operations.h
+
+libgbxdr_la_CFLAGS = -I$(top_srcdir)/utils/
+
+libgbxdr_la_LIBADD = -lgfapi
+
+libgbxdr_ladir = $(includedir)/gluster-block/rpc
+
+DISTCLEANFILES = Makefile.in
+
+CLEANFILES = *~