summaryrefslogtreecommitdiffstats
path: root/rpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rpc/Makefile.am')
-rw-r--r--rpc/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/rpc/Makefile.am b/rpc/Makefile.am
index 4dd7439..8cabcc1 100644
--- a/rpc/Makefile.am
+++ b/rpc/Makefile.am
@@ -6,10 +6,11 @@ libgbrpc_la_SOURCES = block_svc_routines.c glfs-operations.c
noinst_HEADERS = glfs-operations.h
-libgbrpc_la_CFLAGS = $(GFAPI_CFLAGS) -DDATADIR=\"$(localstatedir)\" \
- -I$(top_srcdir)/utils/ -I$(top_builddir)/rpc/rpcl
+libgbrpc_la_CFLAGS = $(GFAPI_CFLAGS) $(JSONC_CFLAGS) \
+ -DDATADIR=\"$(localstatedir)\" \
+ -I$(top_srcdir)/utils/ -I$(top_builddir)/rpc/rpcl
-libgbrpc_la_LIBADD = $(GFAPI_LIBS) $(UUID) rpcl/libgbrpcxdr.la
+libgbrpc_la_LIBADD = $(GFAPI_LIBS) $(JSONC_LIBS) $(UUID) rpcl/libgbrpcxdr.la
libgbrpc_ladir = $(includedir)/gluster-block/rpc