summaryrefslogtreecommitdiffstats
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
index e1545db..798b4a8 100644
--- a/systemd/Makefile.am
+++ b/systemd/Makefile.am
@@ -1,13 +1,18 @@
-DISTCLEANFILES = Makefile.in gluster-blockd.service gluster-block-target.service
+DISTCLEANFILES = Makefile.in gluster-blockd.service gluster-block-target.service \
+ gluster-blockd.initd
-CLEANFILES = *~ gluster-blockd.service gluster-block-target.service
+CLEANFILES = *~ gluster-blockd.service gluster-block-target.service \
+ gluster-blockd.initd
-EXTRA_DIST = gluster-blockd.service.in gluster-block-target.service.in \
- gluster-blockd.sysconfig
+EXTRA_DIST = gluster-blockd.service.in gluster-block-target.service.in \
+ gluster-blockd.initd.in gluster-blockd.sysconfig
if USE_SYSTEMD
# systemddir is already defined through configure.ac
systemd_DATA = gluster-blockd.service gluster-block-target.service
+else
+# initddir is already defined through configure.ac
+initd_DATA = gluster-blockd.initd
endif
install-data-local: