summaryrefslogtreecommitdiffstats
path: root/api/examples/Makefile.am
diff options
context:
space:
mode:
authorJustin Clift <justin@gluster.org>2014-03-21 20:13:16 +0000
committerVijay Bellur <vbellur@redhat.com>2014-03-24 10:31:22 -0700
commitf7a815a2d0e7e9d7ed1ec2da587790bd3ddda9e5 (patch)
treea7d5b9d38f624b83677bf715ff8e3519ba3d189d /api/examples/Makefile.am
parenta8b03479af1cd23baddd373a4d52f366b49c2398 (diff)
features/glupy: Rename Glupy python module to avoid namespace conflict
* Rename gluster.py to glupy.py to avoid namespace conflict (#1018619) * Move the main Glupy files into glusterfs-extra-xlators rpm * Move the Glupy Translator examples into glusterfs-devel rpm * Add Glupy entry to the MAINTAINERS file BUG: 1018619 Change-Id: I48de598ba5ae8eec0e7e276bbcca1abb0e549cef Signed-off-by: Justin Clift <justin@gluster.org> Reviewed-on: http://review.gluster.org/6979 Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Diffstat (limited to 'api/examples/Makefile.am')
-rw-r--r--api/examples/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/api/examples/Makefile.am b/api/examples/Makefile.am
index 05f40ff53..f1a8d12b2 100644
--- a/api/examples/Makefile.am
+++ b/api/examples/Makefile.am
@@ -1,6 +1,10 @@
+# The bits needed for glfsxmp
EXTRA_PROGRAMS = glfsxmp
glfsxmp_SOURCES = glfsxmp.c
glfsxmp_CFLAGS = $(GLFS_CFLAGS) -Wall
glfsxmp_LDADD = $(GLFS_LIBS) -lrt
-EXTRA_DIST = gfapi.py
+# Install __init__.py (a generated file), and gfapi.py into
+# the Python site-packages area
+pygfapidir = $(pythondir)/gluster
+pygfapi_PYTHON = __init__.py gfapi.py