summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2012-11-02 09:15:36 +0100
committerAnand Avati <avati@redhat.com>2012-11-05 16:02:39 -0800
commit04fc3fdb5825fbfacaf610c6d86c5a4766f16ee3 (patch)
treeffc5bb0ee1538d8a59e8d7cf9268ff87d1b4d0e0 /configure.ac
parentb872ccf50845a6aaee71a938ae4186e86d09aedc (diff)
POSIX sh uses = and not ==
BUG: 815227 Change-Id: I5a498f1b917fb658914133ee071783e7b8e0d025 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/4151 Reviewed-by: Jeff Darcy <jdarcy@redhat.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7dda2f3ab..4e638d563 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,7 +379,7 @@ AC_ARG_ENABLE([systemtap],
[Enable inclusion of systemtap trace support])],
[ENABLE_SYSTEMTAP="${enableval}"], [ENABLE_SYSTEMTAP="def"])
-AM_CONDITIONAL([ENABLE_SYSTEMTAP], [test "x${ENABLE_SYSTEMTAP}" == "xyes"])
+AM_CONDITIONAL([ENABLE_SYSTEMTAP], [test "x${ENABLE_SYSTEMTAP}" = "xyes"])
AC_MSG_RESULT(${ENABLE_SYSTEMTAP})
if test "x${ENABLE_SYSTEMTAP}" != "xno"; then
@@ -388,15 +388,15 @@ if test "x${ENABLE_SYSTEMTAP}" != "xno"; then
[SDT_H_FOUND="no"])
fi
-if test "x${ENABLE_SYSTEMTAP}" == "xyes"; then
- if test "x${DTRACE}" == "xno"; then
+if test "x${ENABLE_SYSTEMTAP}" = "xyes"; then
+ if test "x${DTRACE}" = "xno"; then
AC_MSG_ERROR([dtrace not found])
- elif test "$x{SDT_H_FOUND}" == "xno"; then
+ elif test "$x{SDT_H_FOUND}" = "xno"; then
AC_MSG_ERROR([systemtap support needs sys/sdt.h header])
fi
fi
-if test "x${DTRACE}" == "xyes" -a "x${SDT_H_FOUND}" == "xyes"; then
+if test "x${DTRACE}" = "xyes" -a "x${SDT_H_FOUND}" = "xyes"; then
AC_MSG_CHECKING([x"${DTRACE}"xy"${SDT_H_FOUND}"y])
AC_DEFINE([HAVE_SYSTEMTAP], [1], [Define to 1 if using probes.])
BUILD_SYSTEMTAP=yes