summaryrefslogtreecommitdiffstats
path: root/api/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'api/examples/Makefile.am')
-rw-r--r--api/examples/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/api/examples/Makefile.am b/api/examples/Makefile.am
index 05f40ff53..f1a8d12b2 100644
--- a/api/examples/Makefile.am
+++ b/api/examples/Makefile.am
@@ -1,6 +1,10 @@
+# The bits needed for glfsxmp
EXTRA_PROGRAMS = glfsxmp
glfsxmp_SOURCES = glfsxmp.c
glfsxmp_CFLAGS = $(GLFS_CFLAGS) -Wall
glfsxmp_LDADD = $(GLFS_LIBS) -lrt
-EXTRA_DIST = gfapi.py
+# Install __init__.py (a generated file), and gfapi.py into
+# the Python site-packages area
+pygfapidir = $(pythondir)/gluster
+pygfapi_PYTHON = __init__.py gfapi.py