summaryrefslogtreecommitdiffstats
path: root/xlators/encryption/rot-13/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/encryption/rot-13/src/Makefile.am')
-rw-r--r--xlators/encryption/rot-13/src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/xlators/encryption/rot-13/src/Makefile.am b/xlators/encryption/rot-13/src/Makefile.am
new file mode 100644
index 000000000..ba5e623d8
--- /dev/null
+++ b/xlators/encryption/rot-13/src/Makefile.am
@@ -0,0 +1,14 @@
+xlator_LTLIBRARIES = rot-13.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/encryption
+
+rot_13_la_LDFLAGS = -module -avoidversion
+
+rot_13_la_SOURCES = rot-13.c
+rot_13_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = rot-13.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)
+
+CLEANFILES =