summaryrefslogtreecommitdiffstats
path: root/contrib/argp-standalone/Makefile.am
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-03-26 16:55:12 -0700
committerAnand Avati <avati@redhat.com>2014-04-04 21:52:10 -0700
commitb66568b6cb6694016f95e9d5a5220d3bde76907d (patch)
tree02dd9b7cf88a65cb4b3661fbce300c733c967ccc /contrib/argp-standalone/Makefile.am
parentd8dd4049143c191cea451bade470b906c67dbbe0 (diff)
build: move argp-standalone into contrib/ directory
Change-Id: Iedcddf95c3577da644c0aebbb297b04c93f1b6fe BUG: 1081274 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-on: http://review.gluster.org/7352 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'contrib/argp-standalone/Makefile.am')
-rw-r--r--contrib/argp-standalone/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/contrib/argp-standalone/Makefile.am b/contrib/argp-standalone/Makefile.am
new file mode 100644
index 000000000..4775d4876
--- /dev/null
+++ b/contrib/argp-standalone/Makefile.am
@@ -0,0 +1,38 @@
+# From glibc
+
+# Copyright (C) 1997, 2003, 2004 Free Software Foundation, Inc.
+# This file is part of the GNU C Library.
+
+# The GNU C Library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+
+# The GNU C Library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public
+# License along with the GNU C Library; see the file COPYING.LIB. If
+# not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+AUTOMAKE_OPTIONS = foreign
+SUBDIRS = .
+
+LIBOBJS = @LIBOBJS@
+
+noinst_LIBRARIES = libargp.a
+
+noinst_HEADERS = argp.h argp-fmtstream.h argp-namefrob.h
+
+EXTRA_DIST = mempcpy.c strchrnul.c strndup.c strcasecmp.c vsnprintf.c autogen.sh
+
+# Leaves out argp-fs-xinl.c and argp-xinl.c
+libargp_a_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
+ argp-help.c argp-parse.c argp-pv.c \
+ argp-pvh.c
+
+libargp_a_LIBADD = $(LIBOBJS)
+
+