summaryrefslogtreecommitdiffstats
path: root/xlators/mgmt/glusterd/src/Makefile.am
diff options
context:
space:
mode:
authorJeff Darcy <jdarcy@redhat.com>2011-10-03 13:56:23 -0400
committerAnand Avati <avati@gluster.com>2011-11-24 00:11:44 -0800
commit86ed5d68596e577b4d923750a619a6921f2cfe18 (patch)
tree77f79cb4202b329622b9e17e60fb52d4f6c1ac08 /xlators/mgmt/glusterd/src/Makefile.am
parent3f1092c1a79adefd4400bfb6fd20029a22b0f827 (diff)
Add volfile-generation hook facility.
Change-Id: I958c393ce5cfffcde8d120499a43dbe6105a082c BUG: 3688 Reviewed-on: http://review.gluster.com/558 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@gluster.com>
Diffstat (limited to 'xlators/mgmt/glusterd/src/Makefile.am')
-rw-r--r--xlators/mgmt/glusterd/src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/xlators/mgmt/glusterd/src/Makefile.am b/xlators/mgmt/glusterd/src/Makefile.am
index e1495c273..817f02735 100644
--- a/xlators/mgmt/glusterd/src/Makefile.am
+++ b/xlators/mgmt/glusterd/src/Makefile.am
@@ -1,5 +1,6 @@
xlator_LTLIBRARIES = glusterd.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/mgmt
+glusterd_la_CPPFLAGS = "-DFILTERDIR=\"$(libdir)/glusterfs/$(PACKAGE_VERSION)/filter\""
glusterd_la_LDFLAGS = -module -avoidversion $(LIBXML2_LIBS)
glusterd_la_SOURCES = glusterd.c glusterd-handler.c glusterd-sm.c glusterd-op-sm.c \
glusterd-utils.c glusterd-rpc-ops.c glusterd-store.c glusterd-handshake.c \