summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae0bc78c4..500b1e93b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,12 @@ AC_CONFIG_FILES([Makefile
xlators/cluster/Makefile
xlators/cluster/afr/Makefile
xlators/cluster/afr/src/Makefile
+ xlators/cluster/nsr-server/Makefile
+ xlators/cluster/nsr-server/src/Makefile
+ xlators/cluster/nsr-recon/Makefile
+ xlators/cluster/nsr-recon/src/Makefile
+ xlators/cluster/nsr-client/Makefile
+ xlators/cluster/nsr-client/src/Makefile
xlators/cluster/stripe/Makefile
xlators/cluster/stripe/src/Makefile
xlators/cluster/dht/Makefile
@@ -289,6 +295,7 @@ fi
AC_CHECK_TOOL([LD],[ld])
AC_CHECK_LIB([crypto], [MD5], , AC_MSG_ERROR([OpenSSL crypto library is required to build glusterfs]))
+AC_CHECK_LIB([curl], curl_version, ,AC_MSG_ERROR([libcurl library is required to build glusterfs]))
AC_CHECK_LIB([pthread], [pthread_mutex_init], , AC_MSG_ERROR([Posix threads library is required to build glusterfs]))
@@ -844,6 +851,19 @@ fi
AM_CONDITIONAL([ENABLE_SYSLOG], [test x$USE_SYSLOG = xyes])
#end syslog section
+
+#etcd section
+AC_CHECK_PROG(ETCD,etcd,yes)
+
+ETCD_SIM=yes
+if test "x${ETCD}" = "xyes"; then
+ ETCD_SIM=no
+ AC_DEFINE(HAVE_ETCD, 1, [define if found etcd])
+fi
+AM_CONDITIONAL([ENABLE_ETCD_SIM], [test x$ETCD_SIM = xyes])
+#end etcd section
+
+
BUILD_READLINE=no
AC_CHECK_LIB([readline -lcurses],[readline],[RLLIBS="-lreadline -lcurses"])
AC_CHECK_LIB([readline -ltermcap],[readline],[RLLIBS="-lreadline -ltermcap"])