summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@f22node1.kkeithle.usersys.redhat.com>2015-03-13 14:22:14 -0400
committerKaleb S. KEITHLEY <kkeithle@f22node1.kkeithle.usersys.redhat.com>2015-03-13 14:32:49 -0400
commita0aa6fb91ac0cdd52769fa8c3cdbf63e48ff63db (patch)
tree3e97e08c087d8ada23ddb951e2a2802cf6cdb2ce /Makefile.am
parentb037cfe399b91182d55708526645c72f324f98af (diff)
build: argp-standalone, conditional build and build with gcc-5
This patch is a backport of two patches on the master branch: 1) BZ 1086773, http://review.gluster.org/7440 commit 09d2dcac3a238cfe6bde1a7aed06facfa16caf20 Change-Id: Id0fcb717b5821d8a4c176e6274339f46b3a4a249 2) BZ 764655, http://review.gluster.org/6034 commit b2dfa011a3fdcb7d22764d143517d0fbd1c2a201 Change-Id: If5dfdc9c7427bd3d39d8da8f79e33ae2da6a3137 In summary: conditionally build argp-standalone, and address compile issues when compiling with gcc-5 Change-Id: Id0f36f0ca4a3775556c9ca524035cd27b4ded55d BUG: 1201898 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@f22node1.kkeithle.usersys.redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a6f2a9d1750..e3ea9b55b81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,10 @@
EXTRA_DIST = autogen.sh \
COPYING-GPLV2 COPYING-LGPLV3 \
INSTALL README AUTHORS THANKS NEWS \
- glusterfs.spec glusterfs-api.pc.in
+ glusterfs.spec glusterfs-api.pc.in \
+ argp-standalone
-SUBDIRS = argp-standalone libglusterfs rpc api xlators glusterfsd \
+SUBDIRS = $(ARGP_STANDALONE_DIR) libglusterfs rpc api xlators glusterfsd \
$(FUSERMOUNT_SUBDIR) doc extras cli
pkgconfigdir = @pkgconfigdir@
@@ -18,7 +19,12 @@ gitclean: distclean
rm -fr autom4te.cache
rm -f missing aclocal.m4 config.h.in config.guess config.sub ltmain.sh install-sh configure depcomp
rm -fr argp-standalone/autom4te.cache
- rm -f argp-standalone/aclocal.m4 argp-standalone/config.h.in argp-standalone/configure argp-standalone/depcomp argp-standalone/install-sh argp-standalone/missing
+ rm -f argp-standalone/aclocal.m4
+ rm -f argp-standalone/config.h.in
+ rm -f argp-standalone/configure
+ rm -f argp-standalone/depcomp
+ rm -f argp-standalone/install-sh
+ rm -f argp-standalone/missing
dist-hook:
(cd $(srcdir) && git diff && echo ===== git log ==== && git log) > $(distdir)/ChangeLog