summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
authorHendrik Visage <hvjunk@gmail.com>2017-05-19 12:21:37 +0530
committerKaleb KEITHLEY <kkeithle@redhat.com>2017-06-20 12:42:01 +0000
commit3183ca1bdee9cb0af22c017e3c610add8ff2b405 (patch)
tree7fc3036b96154701853ce8826bf129a71ca42af3 /extras/Makefile.am
parenta052b413242783f39cb3312a6a02bdd025b10f0c (diff)
scripts/shared_storage : systemd helper scripts to mount shared storage post reboot
Reported-by: Hendrik Visage <hvjunk@gmail.com> Change-Id: Ibcff56b00f45c8af54c1ae04974267c2180f5f63 BUG: 1452527 Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com> Reviewed-on: https://review.gluster.org/17339 Smoke: Gluster Build System <jenkins@build.gluster.org> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.org> Reviewed-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index 3af11032f6b..68637724a48 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -1,5 +1,8 @@
addonexecdir = $(GLUSTERFS_LIBEXECDIR)
addonexec_SCRIPTS = peer_add_secret_pub
+if USE_SYSTEMD
+addonexec_SCRIPTS += mount-shared-storage.sh
+endif
EditorModedir = $(docdir)
EditorMode_DATA = glusterfs-mode.el glusterfs.vim
@@ -22,7 +25,8 @@ EXTRA_DIST = $(conf_DATA) specgen.scm glusterfs-mode.el glusterfs.vim \
disk_usage_sync.sh clear_xattrs.sh glusterd-sysconfig glusterd.vol \
post-upgrade-script-for-quota.sh pre-upgrade-script-for-quota.sh \
command-completion/gluster.bash command-completion/Makefile \
- command-completion/README stop-all-gluster-processes.sh clang-checker.sh
+ command-completion/README stop-all-gluster-processes.sh clang-checker.sh \
+ mount-shared-storage.sh
install-data-local:
if [ -n "$(tmpfilesdir)" ]; then \