summaryrefslogtreecommitdiffstats
path: root/xlators/experimental/dht2/dht2-client/src/Makefile.am
diff options
context:
space:
mode:
authorShyam <srangana@redhat.com>2016-02-08 14:44:32 +0530
committerJeff Darcy <jdarcy@redhat.com>2016-03-24 08:05:57 -0700
commitaebd8d69d9c918a55f0619303de6880a4214dc94 (patch)
tree4b26ddb2da83f97e31526d6eb0e96599c2b8174d /xlators/experimental/dht2/dht2-client/src/Makefile.am
parent91004b046805243e730176a5354ce3092326dde4 (diff)
dht2: Creation of experimental shell for dht2
Change-Id: I1aa3ea25f99d36fa2356edaa4c3132386adef303 Signed-off-by: Shyam <srangana@redhat.com> Reviewed-on: http://review.gluster.org/13397 Smoke: Gluster Build System <jenkins@build.gluster.com> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Diffstat (limited to 'xlators/experimental/dht2/dht2-client/src/Makefile.am')
-rw-r--r--xlators/experimental/dht2/dht2-client/src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/xlators/experimental/dht2/dht2-client/src/Makefile.am b/xlators/experimental/dht2/dht2-client/src/Makefile.am
new file mode 100644
index 00000000000..39132994d08
--- /dev/null
+++ b/xlators/experimental/dht2/dht2-client/src/Makefile.am
@@ -0,0 +1,19 @@
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/experimental
+xlator_LTLIBRARIES = dht2c.la
+
+dht2c_sources = dht2-client-main.c
+
+dht2common_sources = $(top_srcdir)/xlators/experimental/dht2/dht2-common/src/dht2-common-map.c
+
+dht2c_la_SOURCES = $(dht2c_sources) $(dht2common_sources)
+dht2c_la_LDFLAGS = -module -avoid-version
+dht2c_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+AM_CPPFLAGS = $(GF_CPPFLAGS)
+AM_CPPFLAGS += -I$(top_srcdir)/xlators/experimental/dht2/dht2-common/src/
+AM_CPPFLAGS += -I$(top_srcdir)/libglusterfs/src
+AM_CPPFLAGS += -I$(top_srcdir)/xlators/lib/src
+
+CLEANFILES =