summaryrefslogtreecommitdiffstats
path: root/xlators/features/bit-rot/src/stub/Makefile.am
diff options
context:
space:
mode:
authorRaghavendra Bhat <raghavendra@redhat.com>2015-11-02 11:43:12 +0530
committerVenky Shankar <vshankar@redhat.com>2015-11-22 20:02:38 -0800
commit26abf56130c37bb47676658c0a0211164f05ed24 (patch)
treec15cf3cc6a9435d0ee580680eb08a3334457e625 /xlators/features/bit-rot/src/stub/Makefile.am
parent7fbc38531acbc39369d3b91ba126fc4147ab89d1 (diff)
features/bit-rot: stub changes for showing bad objects in the status
Change-Id: If905132f6f1df4aebd9ab255e1e8c59902f84fe5 BUG: 1207627 Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com> Reviewed-on: http://review.gluster.org/12503 Tested-by: NetBSD Build System <jenkins@build.gluster.org> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Venky Shankar <vshankar@redhat.com>
Diffstat (limited to 'xlators/features/bit-rot/src/stub/Makefile.am')
-rw-r--r--xlators/features/bit-rot/src/stub/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/xlators/features/bit-rot/src/stub/Makefile.am b/xlators/features/bit-rot/src/stub/Makefile.am
index 5b5253c4ad5..1746344f1b0 100644
--- a/xlators/features/bit-rot/src/stub/Makefile.am
+++ b/xlators/features/bit-rot/src/stub/Makefile.am
@@ -3,13 +3,14 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
bitrot_stub_la_LDFLAGS = $(GF_XLATOR_DEFAULT_LDFLAGS)
-bitrot_stub_la_SOURCES = bit-rot-stub.c
+bitrot_stub_la_SOURCES = bit-rot-stub-helpers.c bit-rot-stub.c
bitrot_stub_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
noinst_HEADERS = bit-rot-stub.h bit-rot-common.h bit-rot-stub-mem-types.h \
bit-rot-object-version.h bit-rot-stub-messages.h
-AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
+ -I$(top_srcdir)/rpc/xdr/src -I$(top_srcdir)/rpc/rpc-lib/src
AM_CFLAGS = -Wall $(GF_CFLAGS)