summaryrefslogtreecommitdiffstats
path: root/xlators/meta/src/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@redhat.com>2014-03-26 11:52:53 -0700
committerAnand Avati <avati@redhat.com>2014-05-05 17:28:55 -0700
commit8160399a36eff62a49a066f16dea9140d877c5e8 (patch)
treee51d49bd93ff98822986569fdfada5d2819546b0 /xlators/meta/src/Makefile.am
parent7fba3a88f1ced610eca0c23516a1e720d75160cd (diff)
meta: (re-)Implement Meta translator
The meta translator exposes details about glusterfs itself in the form of a virtual namespace. Loading the translator on the client side creates the meta virtual view under $mntpoint/.meta by default. The directory is not listed (even with ls -a) and can be accessed by doing a "cd /mnt/.meta" Change-Id: I5ffdf39203841a9562a8280a1f79dc76d4dded5d BUG: 1089216 Signed-off-by: Anand Avati <avati@redhat.com> Reviewed-on: http://review.gluster.org/7509 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
Diffstat (limited to 'xlators/meta/src/Makefile.am')
-rw-r--r--xlators/meta/src/Makefile.am38
1 files changed, 32 insertions, 6 deletions
diff --git a/xlators/meta/src/Makefile.am b/xlators/meta/src/Makefile.am
index f8fa7d4cb13..530fea9792b 100644
--- a/xlators/meta/src/Makefile.am
+++ b/xlators/meta/src/Makefile.am
@@ -1,11 +1,37 @@
-xlator_PROGRAMS = meta.so
-xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/
+xlator_LTLIBRARIES = meta.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator
-meta_so_SOURCES = meta.c tree.c misc.c view.c
-noinst_HEADERS = meta.h tree.h misc.h view.h
+meta_la_LDFLAGS = -module -avoid-version
+
+meta_la_SOURCES = meta.c meta-helpers.c meta-defaults.c \
+ plugins/root-dir.c \
+ plugins/graphs-dir.c \
+ plugins/frames-file.c \
+ plugins/graph-dir.c \
+ plugins/active-link.c \
+ plugins/xlator-dir.c \
+ plugins/top-link.c \
+ plugins/logging-dir.c \
+ plugins/logfile-link.c \
+ plugins/loglevel-file.c \
+ plugins/process_uuid-file.c \
+ plugins/volfile-file.c \
+ plugins/view-dir.c \
+ plugins/subvolumes-dir.c \
+ plugins/subvolume-link.c \
+ plugins/type-file.c \
+ plugins/version-file.c \
+ plugins/options-dir.c \
+ plugins/option-file.c \
+ plugins/cmdline-file.c \
+ plugins/name-file.c
+
+meta_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = meta.h meta-hooks.h meta-mem-types.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
-AM_CFLAGS = -Wall
+AM_CFLAGS = -Wall $(GF_CFLAGS)
-CLEANFILES =
+CLEANFILES =