summaryrefslogtreecommitdiffstats
path: root/xlators/system/posix-acl/src/Makefile.am
diff options
context:
space:
mode:
authorPranith Kumar K <pkarampu@redhat.com>2016-11-13 16:43:36 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2016-11-17 01:56:14 -0800
commit35e8ecabd7db36431ea93f523095bc21078ecef8 (patch)
tree9721a2ae9491e68a3d1d6346c22a05ac64dd1b60 /xlators/system/posix-acl/src/Makefile.am
parent53a76d6e3bbd597a11778ce252709eaa86ac5125 (diff)
system/posix-acl: Log reason for EACCES
It is becoming increasingly difficult to debug the reason why posix-acl decides to fail a fop with EACCES. This patch prints a big log everytime such a condition occurs giving out the details that may help in finding why the fop is errored out. Change-Id: I2505baaafb5d77ef6c187554ff027df9b20468db BUG: 1394548 Signed-off-by: Pranith Kumar K <pkarampu@redhat.com> Reviewed-on: http://review.gluster.org/15837 Smoke: Gluster Build System <jenkins@build.gluster.org> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.org> Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
Diffstat (limited to 'xlators/system/posix-acl/src/Makefile.am')
-rw-r--r--xlators/system/posix-acl/src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/xlators/system/posix-acl/src/Makefile.am b/xlators/system/posix-acl/src/Makefile.am
index c2214ecf4c9..f57070ce4a4 100644
--- a/xlators/system/posix-acl/src/Makefile.am
+++ b/xlators/system/posix-acl/src/Makefile.am
@@ -4,7 +4,8 @@ posix_acl_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
posix_acl_la_SOURCES = posix-acl.c posix-acl-xattr.c
posix_acl_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-noinst_HEADERS = posix-acl.h posix-acl-xattr.h posix-acl-mem-types.h
+noinst_HEADERS = posix-acl.h posix-acl-xattr.h posix-acl-mem-types.h \
+ posix-acl-messages.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
-I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src