summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d90307023f..c5e0da84a8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,6 +134,26 @@ AC_CANONICAL_HOST
AC_PROG_CC
AC_PROG_LIBTOOL
+# texinfo check
+AC_CHECK_PROG([INFO], [makeinfo], [yes], [no])
+if test "x$INFO" = "xno"; then
+ AC_MSG_WARN([
+*** Makeinfo is missing. Info documentation will not be built.])
+ BUILD_INFO=
+else
+ BUILD_INFO=user-guide
+ case "$INFO" in
+ */missing\ makeinfo*)
+ BUILD_INFO=
+ AC_MSG_WARN([
+*** Makeinfo is missing. Info documentation will not be built.])
+ ;;
+ *)
+ esac
+fi
+AC_SUBST(INFO)
+AC_SUBST(BUILD_INFO)
+
# LEX needs a check
AC_PROG_LEX
if test "x${LEX}" != "xflex" -a "x${FLEX}" != "xlex"; then