summaryrefslogtreecommitdiffstats
path: root/tests/basic/gfapi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/basic/gfapi/Makefile.am')
-rw-r--r--tests/basic/gfapi/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/basic/gfapi/Makefile.am b/tests/basic/gfapi/Makefile.am
new file mode 100644
index 00000000000..2041112a7af
--- /dev/null
+++ b/tests/basic/gfapi/Makefile.am
@@ -0,0 +1,15 @@
+## compiles against the *system* version of libgfapi,
+## but not the libgfapi for the testcases
+
+CFLAGS = -Wall -g $(shell pkg-config --cflags glusterfs-api)
+LDFLAGS = $(shell pkg-config --libs glusterfs-api)
+
+BINARIES = upcall-cache-invalidate
+
+%: %.c
+
+all: $(BINARIES)
+
+clean:
+ -$(RM) $(BINARIES)
+