summaryrefslogtreecommitdiffstats
path: root/xlators/experimental/encryption/rot-13/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/experimental/encryption/rot-13/src/Makefile.am')
-rw-r--r--xlators/experimental/encryption/rot-13/src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/xlators/experimental/encryption/rot-13/src/Makefile.am b/xlators/experimental/encryption/rot-13/src/Makefile.am
new file mode 100644
index 00000000000..1b4bb921279
--- /dev/null
+++ b/xlators/experimental/encryption/rot-13/src/Makefile.am
@@ -0,0 +1,16 @@
+xlator_LTLIBRARIES = rot-13.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/experimental/encryption
+
+rot_13_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
+
+rot_13_la_SOURCES = rot-13.c
+rot_13_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = rot-13.h
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
+ -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+CLEANFILES =