summaryrefslogtreecommitdiffstats
path: root/tools/get_sosreports/setup.py
diff options
context:
space:
mode:
authorkshithijiyer <kshithij.ki@gmail.com>2020-05-29 19:26:39 +0530
committerkshithijiyer <kshithij.ki@gmail.com>2020-06-01 12:24:11 +0530
commit3979be96355f1bc694056c036928df9b71117870 (patch)
tree514ad60ae7246c51eb40cc0e5c98cb601fb21223 /tools/get_sosreports/setup.py
parent1e82a9e5a2275edc5fdfd40d7f9b79334da7682f (diff)
[Tool] Add tool to fetch sosreports
Adding tool to fetch sosreports from all servers and clients using glusto-tests config file. This tool is essentially just a tweeked version of getsos[1] tool which can take glusto-tests config file and is relicensed under GPLv3+. Reference: [1] https://github.com/kshithijiyer/getsos Change-Id: Ic1685163154ed4358064397d74d3965097448621 Signed-off-by: kshithijiyer <kshithij.ki@gmail.com>
Diffstat (limited to 'tools/get_sosreports/setup.py')
-rw-r--r--tools/get_sosreports/setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/tools/get_sosreports/setup.py b/tools/get_sosreports/setup.py
new file mode 100644
index 000000000..79392e7ec
--- /dev/null
+++ b/tools/get_sosreports/setup.py
@@ -0,0 +1,33 @@
+# Copyright (C) 2020 Red Hat, Inc. <http://www.redhat.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY :or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+from setuptools import setup
+
+setup(
+ name='get_sosreports',
+ version="1.0",
+ author='Red Hat, Inc.',
+ author_email='gluster-devel@gluster.org',
+ url='http://www.gluster.org',
+ licens="GPLv3+",
+ description=("Tool to collect sosreports"
+ " from all servers and clients"),
+ py_modules=['get_sosreports'],
+ entry_points="""
+ [console_scripts]
+ get_sosreports = get_sosreports:main
+ """
+)