summaryrefslogtreecommitdiffstats
path: root/rpc/Makefile.am
diff options
context:
space:
mode:
authorPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2017-03-22 12:43:20 +0530
committerPranith Kumar K <pkarampu@redhat.com>2017-04-28 11:43:02 +0530
commit7e29a1a2496a922457bdeb02332e9b78c97b4d81 (patch)
tree2e3090df6519e98718ddfc58ae0e23ddcaa5140a /rpc/Makefile.am
parentbd772be0685479c2fe27e15a3289384a56cf4c31 (diff)
gluster-block: support json response
This is how cli response looks like, on supplying '--json*' flag to cmd-args: $ gluster-block create block-test/sample-block1 ha 1 localhost.localdomain 1GiB --json (or) $ gluster-block create block-test/sample-block2 ha 1 localhost.localdomain 1GiB --json-spaced { "IQN": "iqn.2016-12.org.gluster-block:681af106-85f1-4a02-a122-57c80903458c", \ "PORTAL(S)": [ "localhost.localdomain:3260" ], "RESULT": "SUCCESS" } $ gluster-block create block-test/sample-block3 ha 1 localhost.localdomain 1GiB --json-plain {"IQN":"iqn.2016-12.org.gluster-block:0fdf6647-57f2-477f-8dd4-54a3de06e410",\ "PORTAL(S)":["localhost.localdomain:3260"],"RESULT":"SUCCESS"} $ gluster-block create block-test/sample-block4 ha 1 localhost.localdomain 1GiB --json-pretty { "IQN":"iqn.2016-12.org.gluster-block:e92ca4a0-5325-4c4b-a407-9e75790e4c7f", "PORTAL(S)":[ "localhost.localdomain:3260" ], "RESULT":"SUCCESS" } Change-Id: Ie51039e3dee0b3357d2347b4087e0fbe299aa29e Fixes: #3 Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Diffstat (limited to 'rpc/Makefile.am')
-rw-r--r--rpc/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/rpc/Makefile.am b/rpc/Makefile.am
index 4dd7439..8cabcc1 100644
--- a/rpc/Makefile.am
+++ b/rpc/Makefile.am
@@ -6,10 +6,11 @@ libgbrpc_la_SOURCES = block_svc_routines.c glfs-operations.c
noinst_HEADERS = glfs-operations.h
-libgbrpc_la_CFLAGS = $(GFAPI_CFLAGS) -DDATADIR=\"$(localstatedir)\" \
- -I$(top_srcdir)/utils/ -I$(top_builddir)/rpc/rpcl
+libgbrpc_la_CFLAGS = $(GFAPI_CFLAGS) $(JSONC_CFLAGS) \
+ -DDATADIR=\"$(localstatedir)\" \
+ -I$(top_srcdir)/utils/ -I$(top_builddir)/rpc/rpcl
-libgbrpc_la_LIBADD = $(GFAPI_LIBS) $(UUID) rpcl/libgbrpcxdr.la
+libgbrpc_la_LIBADD = $(GFAPI_LIBS) $(JSONC_LIBS) $(UUID) rpcl/libgbrpcxdr.la
libgbrpc_ladir = $(includedir)/gluster-block/rpc