summaryrefslogtreecommitdiffstats
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
authorPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2017-08-11 22:19:38 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2017-09-15 13:56:25 +0000
commitf20605d85396132575a83da6b827f854c03dbf01 (patch)
tree75a98b0e5de4fb92009e53248425de43ae1f1f3b /systemd/Makefile.am
parent9d76a57dc9cd804f15042ccd683b7d05e35b9b7a (diff)
systemd: fix systemd dependency list
This patch brings a wrapper target service unit 'gluster-block-target.service' which ensures tcmu-runner gets activated. To fix this properly we need a change in tcmu-runner [1] unit which has to define precedence of glusterd service. [1] https://github.com/open-iscsi/tcmu-runner/pull/296 Change-Id: I32d7d82eec03e0cc9111eb58241190af30244a3c Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
index 2cdda4c..bbec9d4 100644
--- a/systemd/Makefile.am
+++ b/systemd/Makefile.am
@@ -2,11 +2,12 @@ DISTCLEANFILES = Makefile.in gluster-blockd.service
CLEANFILES = *~ gluster-blockd.service
-EXTRA_DIST = gluster-blockd.service.in gluster-blockd.sysconfig
+EXTRA_DIST = gluster-blockd.service.in gluster-block-target.service \
+ gluster-blockd.sysconfig
if USE_SYSTEMD
# systemddir is already defined through configure.ac
-systemd_DATA = gluster-blockd.service
+systemd_DATA = gluster-blockd.service gluster-block-target.service
endif
install-data-local: