summaryrefslogtreecommitdiffstats
path: root/plugins/volcap/setup.py
diff options
context:
space:
mode:
authorRamesh Nachimuthu <rnachimu@redhat.com>2014-06-17 16:26:20 +0530
committerBala FA <barumuga@redhat.com>2014-08-14 01:44:22 -0700
commite0bdeafae88282506ceb23b948354ccba658e7af (patch)
tree622f4ac6c6e19fcedd76440cab78af78035fc36e /plugins/volcap/setup.py
parent7ae262aa79b9c051b82d7a88910a8ff6f1dcd46e (diff)
nagios-addons: Using ctypes to call gfapi
Removing the volCap.c which was used to call libgfapi and calling libgfapi directly from python using ctypes. Change-Id: Ia78f212c769c34e5cb991e429623946a4256e2af Signed-off-by: Ramesh Nachimuthu <rnachimu@redhat.com> Reviewed-on: http://review.gluster.org/8090 Reviewed-by: Sahina Bose <sabose@redhat.com> Reviewed-by: Bala FA <barumuga@redhat.com>
Diffstat (limited to 'plugins/volcap/setup.py')
-rw-r--r--plugins/volcap/setup.py11
1 files changed, 0 insertions, 11 deletions
diff --git a/plugins/volcap/setup.py b/plugins/volcap/setup.py
deleted file mode 100644
index b37e090..0000000
--- a/plugins/volcap/setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
-from distutils.core import setup, Extension
-
-module1 = Extension('capacity',
- sources=['volCap.c'], libraries=['gfapi'])
-
-setup(name='capacity',
- version='1.0',
- description='Gets the volume capcity Utilization',
- py_modules=['__init__'],
- url='redhat.com',
- ext_modules=[module1])