summaryrefslogtreecommitdiffstats
path: root/plugins/volcap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/volcap/Makefile.am')
-rw-r--r--plugins/volcap/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/plugins/volcap/Makefile.am b/plugins/volcap/Makefile.am
new file mode 100644
index 0000000..6365336
--- /dev/null
+++ b/plugins/volcap/Makefile.am
@@ -0,0 +1,22 @@
+
+dist_glusternagiosplugins_PYTHON = \
+ volcap.so \
+ $(NULL)
+
+volcap.so: volCap.c setup.py
+ (cd $(srcdir); $(PYTHON) setup.py build \
+ --build-temp $(abs_builddir) --build-lib $(abs_builddir))
+all-local: volcap.so
+
+EXTRA_DIST = \
+ $(NULL)
+
+EXTRA_DIST = \
+ __init__.py \
+ volCap.c \
+ tests.py \
+ setup.py
+
+CLEANFILES = \
+ volcap.o \
+ volcap.so