summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLuis Pabon <lpabon@redhat.com>2013-09-19 13:18:17 -0400
committerPeter Portante <pportant@redhat.com>2013-09-20 12:51:17 -0700
commitb8bc40250811cce0869d68d372051733dbe4cb84 (patch)
tree6376c4013a3f1791a0e598aab9adac901df250ef /setup.py
parent7d5e6ed57e4b818c5b8b130b53f57d47dc20e327 (diff)
Use tox to satisfy functional test requirements
Instead of installing and polluting the host development system with the required packages to run the functional tests, it is now possible to run the functional tests from inside tox. All the required packages are installed in the tox environment and run from there. The only external dependencies are that the functional tests still must use /etc/swift for configuration files on the host and /mnt/gluster-object must be on a XFS or GlusterFS volume. Change-Id: I4a949dbcad778018e22c61d09ae1ba5f21a03aec Signed-off-by: Luis Pabon <lpabon@redhat.com> Reviewed-on: http://review.gluster.org/5976 Reviewed-by: Peter Portante <pportant@redhat.com> Tested-by: Peter Portante <pportant@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 12 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 23dd8d6..0fb757d 100644
--- a/setup.py
+++ b/setup.py
@@ -33,15 +33,21 @@ setup(
packages=find_packages(exclude=['test', 'bin']),
test_suite='nose.collector',
classifiers=[
- 'Development Status :: 4 - Beta',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python :: 2.6',
- 'Environment :: No Input/Output (Daemon)',
+ 'Development Status :: 5 - Production/Stable'
+ 'Environment :: OpenStack'
+ 'Intended Audience :: Information Technology'
+ 'Intended Audience :: System Administrators'
+ 'License :: OSI Approved :: Apache Software License'
+ 'Operating System :: POSIX :: Linux'
+ 'Programming Language :: Python'
+ 'Programming Language :: Python :: 2'
+ 'Programming Language :: Python :: 2.6'
+ 'Programming Language :: Python :: 2.7'
],
- install_requires=[], # removed for better compat
+ install_requires=[],
scripts=[
'bin/gluster-swift-gen-builders',
+ 'bin/gluster-swift-print-metadata',
],
entry_points={
'paste.app_factory': [