summaryrefslogtreecommitdiffstats
path: root/api/examples/Makefile.am
diff options
context:
space:
mode:
authorLalatendu Mohanty <lmohanty@redhat.com>2013-10-13 15:08:10 -0400
committerVijay Bellur <vbellur@redhat.com>2013-10-16 00:55:50 -0700
commit656db3a8e0601ba0a6af303b971111fbbed29906 (patch)
treefc3089e5e0e98e62a662f1e721af7a2fe5016f9f /api/examples/Makefile.am
parent0c129ad25c007d574e9c7e45f47e6ba7075f4bfa (diff)
libgfapi: Fix to compilation failure/warnings for examples/glfsxmp.c
The comilation of glfsxmp.c i.e. "make glfsxmp" was failing with "undefined reference to `clock_gettime'" error. Fixed all compilation warnings for unused variables and wrong formart specifier in printf e.g. : "format ‘%d’ expects argument of type ‘int’, but argument 3 has type ‘__syscall_slong_t’ [-Wformat]" Also added the compilation steps for glfsxmp.c in the README file Change-Id: I399ec7c9ad7b6412463c89099d63922caef6749e Signed-off-by: Lalatendu Mohanty <lmohanty@redhat.com> Reviewed-on: http://review.gluster.org/6085 Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com> Reviewed-by: Santosh Pradhan <spradhan@redhat.com> Tested-by: Shyamsundar Ranganathan <srangana@redhat.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'api/examples/Makefile.am')
-rw-r--r--api/examples/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/api/examples/Makefile.am b/api/examples/Makefile.am
index cfb0d3dff..05f40ff53 100644
--- a/api/examples/Makefile.am
+++ b/api/examples/Makefile.am
@@ -1,6 +1,6 @@
EXTRA_PROGRAMS = glfsxmp
glfsxmp_SOURCES = glfsxmp.c
glfsxmp_CFLAGS = $(GLFS_CFLAGS) -Wall
-glfsxmp_LDADD = $(GLFS_LIBS)
+glfsxmp_LDADD = $(GLFS_LIBS) -lrt
EXTRA_DIST = gfapi.py