summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRam Raja <rraja@redhat.com>2013-04-30 00:38:04 +0530
committerAnand Avati <avati@redhat.com>2013-05-10 14:15:08 -0700
commit1e62ff42dfcf84ded563f710cb8da92fa0f41936 (patch)
tree5e0375d69af015878c7a96e643ddebe54af912eb /configure.ac
parent40d026e10013f533c4fee33b87dabc4ca11c94b3 (diff)
glupy: Importing Jeff's glupy project into glusterfs
Change-Id: I3891ef6eaf6ede7c8cbedc3298ce2501a69b2b05 BUG: 961856 Original-author: Jeff Darcy <jdarcy@redhat.com> Signed-off-by: Ram Raja <rraja@redhat.com> Reviewed-on: http://review.gluster.org/4906 Reviewed-by: Justin Clift <jclift@redhat.com> Tested-by: Justin Clift <jclift@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6357b19fa..48237bc40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,6 +95,8 @@ AC_CONFIG_FILES([Makefile
xlators/protocol/server/Makefile
xlators/protocol/server/src/Makefile
xlators/features/Makefile
+ xlators/features/glupy/Makefile
+ xlators/features/glupy/src/Makefile
xlators/features/locks/Makefile
xlators/features/locks/src/Makefile
xlators/features/quota/Makefile
@@ -632,6 +634,14 @@ if test "x$LIBAIO" != "x"; then
fi
+BUILD_GLUPY=no
+AC_CHECK_LIB([python2.6],[PyImport_Import],[BUILD_GLUPY=yes])
+
+if test "x$BUILD_GLUPY" = "xyes"; then
+ GLUPY_SUBDIR=glupy
+fi
+AC_SUBST(GLUPY_SUBDIR)
+
AC_SUBST(GF_HOST_OS)
AC_SUBST([GF_GLUSTERFS_LIBS])
AC_SUBST(GF_GLUSTERFS_CFLAGS)