summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVijaykumar Koppad <vkoppad@redhat.com>2014-02-19 18:51:26 +0530
committerVijay Bellur <vbellur@redhat.com>2014-02-25 20:28:19 -0800
commit64079f83528edb4cc4ae1a85a8633fd578b6e393 (patch)
treed5664e6ea892b533f2fc7d9111e04a7c5443df16 /configure.ac
parentfc01b0293bef8ba14650c6a52f733bb6b6b77954 (diff)
build: fail configure if the libxml2 devel package is missing.
Problem: Geo-replication uses volume info xml output. While installing glusterfs through build+install from source, and if the libxml2-devel package is not present in the system, build will succeed with just warning and XML output : no. If user fails to observe this and doesn't know that geo-rep is dependent on xml output, user won't be able use geo-rep. Solution: If libxml2-devel is unavailable, and if geo-rep is enabled error out in configure, otherwise just warn with XML_OUTPUT = no. If the xml-output is disabled while configuring, error out if geo-rep is enabled, otherwise just warn. Change-Id: Icde5d0c1e5f3b869e7db6ed6a046bdc49b450fcb BUG: 1066997 Signed-off-by: Vijaykumar Koppad <vkoppad@redhat.com> Reviewed-on: http://review.gluster.org/7131 Reviewed-by: Niels de Vos <ndevos@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7c383532e..69d25e4da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -577,10 +577,18 @@ if test "x$enable_xml_output" != "xno"; then
if test "x${no_xml}" = "x"; then
AC_DEFINE([HAVE_LIB_XML], [1], [Define to 1 if using libxml2.])
else
- AC_MSG_WARN([libxml2 devel libraries not found disabling XML support])
- BUILD_XML_OUTPUT="no"
+ if test "x$enable_georeplication" != "xno"; then
+ AC_MSG_ERROR([libxml2 devel libraries not found])
+ else
+ AC_MSG_WARN([libxml2 devel libraries not found disabling XML support])
+ BUILD_XML_OUTPUT="no"
+ fi
+
fi
else
+ if test "x$enable_georeplication" != "xno"; then
+ AC_MSG_ERROR([geo-replication requires xml output])
+ fi
BUILD_XML_OUTPUT="no"
fi
# end of xml-output