summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaushal M <kaushal@redhat.com>2014-02-18 15:44:56 +0530
committerVijay Bellur <vbellur@redhat.com>2014-02-20 08:37:55 -0800
commitf1f91f8016e468718df9c581662f8417a1fb999c (patch)
tree27d37f52837f7a417e3056c2c5bba1dfe5d83116 /configure.ac
parent66e2e76adaed74dae4a3606685460236870c077a (diff)
build: Don't discard CFLAGS in configure
The configure script was discarding the passed CFLAGS inadvertently. This caused failures while building rpms on epel7 and fedora-{19,20}, as the hardened CFLAGS passed by rpmbuild on these distros were discarded which lead to the failure of rpmbuild. Thanks to Neils de Vos for helping track this down. Change-Id: I5b2aa5d449d13bf67df6c19cda178bddfe6c3652 BUG: 1066385 Signed-off-by: Kaushal M <kaushal@redhat.com> Reviewed-on: http://review.gluster.org/7029 Reviewed-by: Justin Clift <jclift@redhat.com> Tested-by: Justin Clift <jclift@redhat.com> Reviewed-by: Niels de Vos <ndevos@redhat.com> Tested-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0c516c4fd..7c383532e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,10 +190,10 @@ AC_ARG_ENABLE([debug],
[Enable debug build options.]))
if test "x$enable_debug" = "xyes"; then
BUILD_DEBUG=yes
- CFLAGS="-g -O0 -DDEBUG"
+ CFLAGS="${CFLAGS} -g -O0 -DDEBUG"
else
BUILD_DEBUG=no
- CFLAGS="-g -O2"
+ CFLAGS="${CFLAGS} -g -O2"
fi
AC_ARG_WITH(pkgconfigdir,