summaryrefslogtreecommitdiffstats
path: root/glusterfsd/src/Makefile.am
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2012-09-24 09:50:44 +0200
committerAnand Avati <avati@redhat.com>2012-09-26 11:17:02 -0700
commitbc2b5977a52baff96ffd69b118967a82d5933555 (patch)
tree4dae5cbe6851e9f41f31f7249dd3e605a5f1fca4 /glusterfsd/src/Makefile.am
parent36db38a5722127e9f330915783cddae453be5db3 (diff)
Fix parallel build issues
Prevent creating symbolic links in not yet created sbindir. Since lex creates two files, make them depend on each other to prevent race condition. Change-Id: I72b633b24de33407006d70571b0a40adaa99dc2b BUG: 859843 Signed-off-by: Kacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com> Reviewed-on: http://review.gluster.org/3968 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'glusterfsd/src/Makefile.am')
-rw-r--r--glusterfsd/src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/glusterfsd/src/Makefile.am b/glusterfsd/src/Makefile.am
index 17d7a4a81..152654fc1 100644
--- a/glusterfsd/src/Makefile.am
+++ b/glusterfsd/src/Makefile.am
@@ -25,6 +25,7 @@ uninstall-local:
install-data-local:
$(INSTALL) -d -m 755 $(DESTDIR)$(localstatedir)/run
$(INSTALL) -d -m 755 $(DESTDIR)$(localstatedir)/log/glusterfs
+ $(INSTALL) -d -m 755 $(DESTDIR)$(sbindir)
rm -f $(DESTDIR)$(sbindir)/glusterfs
rm -f $(DESTDIR)$(sbindir)/glusterd
ln -s glusterfsd $(DESTDIR)$(sbindir)/glusterfs