summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/src/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@gluster.com>2010-07-14 16:26:17 +0000
committerAnand V. Avati <avati@dev.gluster.com>2010-07-14 15:02:50 -0700
commit47dc8def246c6338cb95e71b4656962a5f74ee90 (patch)
treec627dd8f4c0743eccd85143be1399a1e505b95f2 /rpc/xdr/src/Makefile.am
parent2865e149c48eb5ed028cffb12e1e5273b47f2b1d (diff)
protocol/lib: rename files to standardized names and places
- move xlators/protocol/lib/* to rpc/xdr/ - rename CLI and glusterd XDR filenames - remove xlators/protocol/lib (libgfproto1.so) Signed-off-by: Anand V. Avati <avati@blackhole.gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 875 (Implement a new protocol to provide proper backward/forward compatibility) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=875
Diffstat (limited to 'rpc/xdr/src/Makefile.am')
-rw-r--r--rpc/xdr/src/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/rpc/xdr/src/Makefile.am b/rpc/xdr/src/Makefile.am
new file mode 100644
index 000000000..79063cd64
--- /dev/null
+++ b/rpc/xdr/src/Makefile.am
@@ -0,0 +1,20 @@
+lib_LTLIBRARIES = libgfxdr.la
+
+libgfxdr_la_CFLAGS = -fPIC -Wall -g -shared -nostartfiles $(GF_CFLAGS) $(GF_DARWIN_LIBGLUSTERFS_CFLAGS)
+
+libgfxdr_la_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D__USE_FILE_OFFSET64 \
+ -D_GNU_SOURCE -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/rpc/rpc-lib/src
+
+libgfxdr_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
+ $(top_builddir)/rpc/rpc-lib/src/libgfrpc.la
+
+libgfxdr_la_SOURCES = xdr-generic.c \
+ glusterfs3-xdr.c glusterfs3.c \
+ cli1-xdr.c cli1.c \
+ glusterd1-xdr.c glusterd1.c
+
+noinst_HEADERS = xdr-generic.h \
+ glusterfs3-xdr.h glusterfs3.h \
+ cli1-xdr.h cli1.h \
+ glusterd1-xdr.h glusterd1.h