summaryrefslogtreecommitdiffstats
path: root/xlators/protocol/legacy/client/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amar@gluster.com>2010-06-21 04:24:40 +0000
committerAnand V. Avati <avati@dev.gluster.com>2010-06-21 20:21:05 -0700
commitb9b8734a9496ccf5f8ed5527dc7714930a59948b (patch)
treeffcf9187c315b30e23cfa7f68f1d360e246d94c2 /xlators/protocol/legacy/client/src/Makefile.am
parent2a5fada7546032e1fc1b106ddd40e42cc45349e1 (diff)
renamed xlator/protocol to xlator/protocol/legacy
Signed-off-by: Amar Tumballi <amar@gluster.com> Signed-off-by: Raghavendra G <raghavendra@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 875 (Implement a new protocol to provide proper backward/forward compatibility) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=875
Diffstat (limited to 'xlators/protocol/legacy/client/src/Makefile.am')
-rw-r--r--xlators/protocol/legacy/client/src/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/xlators/protocol/legacy/client/src/Makefile.am b/xlators/protocol/legacy/client/src/Makefile.am
new file mode 100644
index 000000000..da00a5182
--- /dev/null
+++ b/xlators/protocol/legacy/client/src/Makefile.am
@@ -0,0 +1,18 @@
+
+xlator_LTLIBRARIES = client.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/protocol
+
+client_la_LDFLAGS = -module -avoidversion
+
+client_la_SOURCES = client-protocol.c saved-frames.c
+client_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
+ $(top_builddir)/xlators/protocol/legacy/lib/src/libgfproto.la
+
+noinst_HEADERS = client-protocol.h saved-frames.h client-mem-types.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS) \
+ -I$(top_srcdir)/xlators/protocol/legacy/lib/src
+
+CLEANFILES =
+