summaryrefslogtreecommitdiffstats
path: root/xlators/storage/bd/src/Makefile.am
diff options
context:
space:
mode:
authorM. Mohan Kumar <mohan@in.ibm.com>2013-11-13 22:44:42 +0530
committerAnand Avati <avati@redhat.com>2013-11-13 11:39:11 -0800
commitb222ce817f5f324fe20d4d3614001ed2f177afb8 (patch)
treebe39e00cea1871b6df3d440199eb9cffd1711823 /xlators/storage/bd/src/Makefile.am
parent6ec9c4599e96de9dcae9426eae6bb1dde4dc7549 (diff)
bd: Add aio support to BD xlator
Volume option bd-aio controls AIO feature for BD xlator. Code taken from posix-aio.c Change-Id: Ib049bd59c9d3f9101d33939838322cfa808de053 BUG: 1028672 Signed-off-by: M. Mohan Kumar <mohan@in.ibm.com> Reviewed-on: http://review.gluster.org/5748 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'xlators/storage/bd/src/Makefile.am')
-rw-r--r--xlators/storage/bd/src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/xlators/storage/bd/src/Makefile.am b/xlators/storage/bd/src/Makefile.am
index 210b7453a..3d93f7442 100644
--- a/xlators/storage/bd/src/Makefile.am
+++ b/xlators/storage/bd/src/Makefile.am
@@ -4,10 +4,10 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/storage
bd_la_LDFLAGS = -module -avoid-version
LIBBD = -llvm2app -lrt
-bd_la_SOURCES = bd.c bd-helper.c
-bd_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(LIBBD)
+bd_la_SOURCES = bd.c bd-helper.c bd-aio.c
+bd_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(LIBBD) $(LIBAIO)
-noinst_HEADERS = bd.h
+noinst_HEADERS = bd.h bd-aio.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
-I$(top_srcdir)/rpc/xdr/src \