summaryrefslogtreecommitdiffstats
path: root/mod_glusterfs/apache/1.3/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mod_glusterfs/apache/1.3/src/Makefile.am')
-rw-r--r--mod_glusterfs/apache/1.3/src/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/mod_glusterfs/apache/1.3/src/Makefile.am b/mod_glusterfs/apache/1.3/src/Makefile.am
new file mode 100644
index 000000000..6bb3075f5
--- /dev/null
+++ b/mod_glusterfs/apache/1.3/src/Makefile.am
@@ -0,0 +1,30 @@
+mod_glusterfs_PROGRAMS = mod_glusterfs.so
+mod_glusterfsdir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/apache/1.3
+
+mod_glusterfs_so_SOURCES = mod_glusterfs.c
+
+all: mod_glusterfs.so
+
+mod_glusterfs.so: $(top_srcdir)/mod_glusterfs/apache/1.3/src/mod_glusterfs.c $(top_builddir)/libglusterfsclient/src/libglusterfsclient.la
+ ln -sf $(top_srcdir)/mod_glusterfs/apache/1.3/src/mod_glusterfs.c $(top_builddir)/mod_glusterfs/apache/1.3/src/mod_glusterfs-build.c
+ $(APXS) -c -Wc,-g3 -Wc,-O0 -D_FILE_OFFSET_BITS=64 -D__USE_FILE_OFFSET64 -D_GNU_SOURCE -I$(top_srcdir)/libglusterfsclient/src -Wl,-rpath,$(libdir) -Wl,-rpath,$(top_builddir)/libglusterfsclient/src/.libs/ $(top_builddir)/libglusterfsclient/src/.libs/libglusterfsclient.so mod_glusterfs-build.c -o $(top_builddir)/mod_glusterfs/apache/1.3/src/mod_glusterfs.so
+
+$(top_builddir)/libglusterfsclient/src/libglusterfsclient.la:
+ $(MAKE) -C $(top_builddir)/libglusterfsclient/src/ all
+
+install-data-local:
+ @echo ""
+ @echo ""
+ @echo "**********************************************************************************"
+ @echo "* TO INSTALL MODGLUSTERFS, PLEASE USE, "
+ @echo "* $(APXS) -n glusterfs -ia $(mod_glusterfsdir)/mod_glusterfs.so "
+ @echo "**********************************************************************************"
+ @echo ""
+ @echo ""
+
+#install:
+# cp -fv mod_glusterfs.so $(HTTPD_LIBEXECDIR)
+# cp -fv httpd.conf $(HTTPD_CONF_DIR)
+
+clean:
+ -rm -fv *.so *.o mod_glusterfs-build.c