summaryrefslogtreecommitdiffstats
path: root/openshift-storage-libs/setup.py
diff options
context:
space:
mode:
authorValerii Ponomarov <vponomar@redhat.com>2019-03-07 20:30:44 +0530
committervponomar <vponomar@redhat.com>2019-03-18 11:34:37 +0000
commit32b611b2a6498b1de307142e335e09d1e0ec082c (patch)
treeaaf600ab6e6adabab7c3facbf30ae6f056731969 /openshift-storage-libs/setup.py
parent0fcdb081517c5904969b89b20326d21b361e448e (diff)
Reorder lib files removing redundant dir layer
Move all the files of 'cns-libs/cnslibs/common' dir to the 'openshift-storage-libs/openshiftstoragelibs', because 'common' is the only dir there, which doesn't really makes sense. And "cns" is old project name, so, replace it with "openshift-storage-libs". Also, fix all the imports of these libs. Change-Id: Ife00a73554e73b21b214b15016b0c8dbbf423446
Diffstat (limited to 'openshift-storage-libs/setup.py')
-rw-r--r--openshift-storage-libs/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/openshift-storage-libs/setup.py b/openshift-storage-libs/setup.py
new file mode 100644
index 00000000..3e528cbf
--- /dev/null
+++ b/openshift-storage-libs/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/python
+from setuptools import setup, find_packages
+
+version = '0.2'
+name = 'openshift-storage-libs'
+
+setup(
+ name=name,
+ version=version,
+ description='Red Hat Container-Native Storage Libraries',
+ author='Red Hat, Inc.',
+ author_email='cns-qe@redhat.com',
+ packages=find_packages(),
+ include_package_data=True,
+ classifiers=[
+ 'Development Status :: 3 - Alpha'
+ 'Intended Audience :: QE, Developers'
+ 'Operating System :: POSIX :: Linux'
+ 'Programming Language :: Python'
+ 'Programming Language :: Python :: 2'
+ 'Programming Language :: Python :: 2.6'
+ 'Programming Language :: Python :: 2.7'
+ 'Topic :: Software Development :: Testing'
+ ],
+ install_requires=['glusto', 'ddt', 'mock', 'rtyaml', 'jsondiff', 'six',
+ 'prometheus_client>=0.4.2'],
+ dependency_links=[
+ 'http://github.com/loadtheaccumulator/glusto/tarball/master#egg=glusto'
+ ],
+)