summaryrefslogtreecommitdiffstats
path: root/templates/setup.py
diff options
context:
space:
mode:
authorArthy Loganathan <aloganat@redhat.com>2017-11-21 00:10:39 +0530
committerArthy Loganathan <aloganat@redhat.com>2017-11-23 10:05:39 +0530
commit46cbb93cb1458484795d114bbf826a77e117e299 (patch)
treebd18345cc4860130f7cea6d63f41883b63c885cf /templates/setup.py
parent868c01161154d79507d1984cd545956f0be43da2 (diff)
Directory structure for cns-qe/cns_automation repo
Change-Id: I8be99fbfa6428b69c31ec2411ff021a2bee6ac45 Signed-off-by: Arthy Loganathan <aloganat@redhat.com>
Diffstat (limited to 'templates/setup.py')
-rw-r--r--templates/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/templates/setup.py b/templates/setup.py
new file mode 100644
index 00000000..26aab045
--- /dev/null
+++ b/templates/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/python
+from setuptools import setup, find_packages
+from distutils import dir_util
+
+version = '0.1'
+name = 'templates'
+
+setup(
+ name=name,
+ version=version,
+ description='Red Hat Container-Native Storage Templates',
+ author='Red Hat, Inc.',
+ author_email='cns-qe@redhat.com',
+ packages=find_packages(),
+ classifiers=[
+ 'Development Status :: 3 - Alpha'
+ 'Intended Audience :: QE, Developers'
+ 'Operating System :: POSIX :: Linux'
+ 'Programming Language :: Python'
+ 'Programming Language :: Python :: 2'
+ 'Programming Language :: Python :: 2.6'
+ 'Programming Language :: Python :: 2.7'
+ 'Topic :: Software Development :: Testing'
+ ],
+ install_requires=['glusto'],
+ dependency_links=['http://github.com/loadtheaccumulator/glusto/tarball/master#egg=glusto'],
+)
+
+dir_util.copy_tree('./cns_common_templates', '/opt/cns_common_templates')