summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2014-04-10 14:43:47 -0400
committerAnand Avati <avati@redhat.com>2014-04-13 14:34:37 -0700
commit09d2dcac3a238cfe6bde1a7aed06facfa16caf20 (patch)
treec543095b6605ee7cae5ea982dfdb6482682db0f1 /Makefile.am
parentc193996c94901d81a2a623799d83ef96f595d3e2 (diff)
configure: argp-standalone is always built, even when not needed
This patch still configures argp, i.e. creates Makefile in /contrib/argp-standalone, for the `make dist`, but there's no reason to compile it when it's not going to be linked into anything. Change-Id: Id0fcb717b5821d8a4c176e6274339f46b3a4a249 BUG: 1086773 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: http://review.gluster.org/7440 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 030a30cdd..b42071db2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,9 +5,10 @@ EXTRA_DIST = autogen.sh \
error-codes.json gf-error-codes.h.template \
gen-headers.py run-tests.sh \
build-aux/pkg-version \
+ contrib/argp-standalone \
$(shell find $(top_srcdir)/tests -type f -print)
-SUBDIRS = contrib/argp-standalone libglusterfs rpc api xlators glusterfsd \
+SUBDIRS = $(ARGP_STANDALONE_DIR) libglusterfs rpc api xlators glusterfsd \
$(FUSERMOUNT_SUBDIR) doc extras cli @SYNCDAEMON_SUBDIR@
pkgconfigdir = @pkgconfigdir@
@@ -21,13 +22,13 @@ gitclean: distclean
find . -name mount.glusterfs -exec rm -f {} \;
rm -fr autom4te.cache
rm -f missing aclocal.m4 config.h.in config.guess config.sub ltmain.sh install-sh configure depcomp
- rm -fr $(CONTRIBDIR)/argp-standalone/autom4te.cache
- rm -f $(CONTRIBDIR)/argp-standalone/aclocal.m4
- rm -f $(CONTRIBDIR)/argp-standalone/config.h.in
- rm -f $(CONTRIBDIR)/argp-standalone/configure
- rm -f $(CONTRIBDIR)/argp-standalone/depcomp
- rm -f $(CONTRIBDIR)/argp-standalone/install-sh
- rm -f $(CONTRIBDIR)/argp-standalone/missing
+ -rm -fr $(CONTRIBDIR)/argp-standalone/autom4te.cache
+ -rm -f $(CONTRIBDIR)/argp-standalone/aclocal.m4
+ -rm -f $(CONTRIBDIR)/argp-standalone/config.h.in
+ -rm -f $(CONTRIBDIR)/argp-standalone/configure
+ -rm -f $(CONTRIBDIR)/argp-standalone/depcomp
+ -rm -f $(CONTRIBDIR)/argp-standalone/install-sh
+ -rm -f $(CONTRIBDIR)/argp-standalone/missing
dist-hook: gen-VERSION gen-ChangeLog
.PHONY: gen-VERSION gen-ChangeLog