summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-04-22 13:27:35 -0700
committerAnand Avati <avati@redhat.com>2014-04-25 13:29:25 -0700
commit9819fcedf10f1430d4969c86e6df4dfe975b7dcf (patch)
treea4ce5b4d8e5666fe6dd66147b5a360670bf51363 /configure.ac
parent40675af8b4a1a90331e353295c75c0ea63457cf6 (diff)
rpcgen: Remove autogenerated files instead build on demand
Avoid modifying autogenerated files and keeping them in repository - autogenerate them on demand from ".x" files Change-Id: I2cdb1fe9b99768ceb80a8cb100fa00bd1d8fe2c6 BUG: 1090807 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-on: http://review.gluster.org/7526 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae945b291..ae0bc78c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,6 +203,11 @@ AC_PROG_CC
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
+AC_CHECK_PROG([RPCGEN], [rpcgen], [yes], [no])
+
+if test "x$RPCGEN" = "xno"; then
+ AC_MSG_ERROR([`rpcgen` not found, glusterfs needs `rpcgen` exiting..])
+fi
# Initialize CFLAGS before usage
AC_ARG_ENABLE([debug],