summaryrefslogtreecommitdiffstats
path: root/booster/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'booster/src/Makefile.am')
-rw-r--r--booster/src/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/booster/src/Makefile.am b/booster/src/Makefile.am
new file mode 100644
index 000000000..9b6e77f95
--- /dev/null
+++ b/booster/src/Makefile.am
@@ -0,0 +1,17 @@
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/performance
+
+ldpreload_PROGRAMS = glusterfs-booster.so
+ldpreloaddir = $(libdir)/glusterfs/
+glusterfs_booster_so_SOURCES = booster.c
+glusterfs_booster_so_CFLAGS = -I$(top_srcdir)/libglusterfsclient/src/ -D_GNU_SOURCE -D$(GF_HOST_OS) -fPIC -Wall \
+ -pthread $(GF_BOOSTER_CFLAGS)
+glusterfs_booster_so_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE \
+ -I$(top_srcdir)/libglusterfsclient/src \
+ -I$(top_srcdir)/libglusterfs/src -DDATADIR=\"$(localstatedir)\" \
+ -DCONFDIR=\"$(sysconfdir)/glusterfs\"
+glusterfs_booster_so_LDFLAGS = -shared -nostartfiles
+glusterfs_booster_so_LDADD = -L$(top_builddir)/libglusterfs/src -lglusterfs \
+ -L$(top_builddir)/libglusterfsclient/src -lglusterfsclient
+
+CLEANFILES =
+