summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Darcy <jdarcy@redhat.com>2012-10-02 10:42:01 -0400
committerAnand Avati <avati@redhat.com>2012-10-02 09:40:29 -0700
commit7d347b2b0fc1c6d5262e42bf6f89e61a1fc18204 (patch)
tree36d3c742e63d1d4dd1b41c438005c0502ad64762 /configure.ac
parent33699838151670aac03f7f21b582419fd7611526 (diff)
build: replace INCLUDES by CPPFLAGS
automake warns: "INCLUDES" is the old name for "AM_CPPFLAGS" (or "*_CPPFLAGS") So abolish INCLUDES, and place the flags into GF_CPPFLAGS which then needs to be mentioned for glusterd. Change-Id: I326f890a69724d8b7163ce726f70ca4618c53958 BUG: 862082 Original-author: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jeff Darcy <jdarcy@redhat.com> Reviewed-on: http://review.gluster.org/4016 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1ba5d496..4f49fbf4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -561,10 +561,10 @@ AC_SUBST(AM_LIBTOOLFLAGS)
CONTRIBDIR='$(top_srcdir)/contrib'
AC_SUBST(CONTRIBDIR)
-GF_CPPFLAGS='-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS)'
+GF_CPPDEFINES='-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS)'
+GF_CPPINCLUDES='-I$(top_srcdir)/libglusterfs/src -I$(CONTRIBDIR)/uuid'
+GF_CPPFLAGS="$GF_CPPDEFINES $GF_CPPINCLUDES"
AC_SUBST([GF_CPPFLAGS])
-INCLUDES='-I$(top_srcdir)/libglusterfs/src -I$(CONTRIBDIR)/uuid'
-AC_SUBST(INCLUDES)
AM_CONDITIONAL([GF_DARWIN_HOST_OS], test "${GF_HOST_OS}" = "GF_DARWIN_HOST_OS")