summaryrefslogtreecommitdiffstats
path: root/ufo/setup.py
diff options
context:
space:
mode:
authorPeter Portante <peter.portante@redhat.com>2013-05-08 21:51:58 -0400
committerAnand Avati <avati@redhat.com>2013-05-10 11:03:55 -0700
commit40d026e10013f533c4fee33b87dabc4ca11c94b3 (patch)
treeaa6315c23a49288b72424f58a71c3f87d8aca7ff /ufo/setup.py
parentfef1270fc2d665c67084c4ce06f60fc8faed4d52 (diff)
object-storage: final removal of ufo code
See https://git.gluster.org/gluster-swift.git for the new location of the Gluster-Swift code. With this patch, no OpenStack Swift related RPMs are constructed. This patch also removes the unused code that references the user.ufo-test xattr key in the DHT translator. Change-Id: I2da32642cbd777737a41c5f9f6d33f059c85a2c1 BUG: 961902 (https://bugzilla.redhat.com/show_bug.cgi?id=961902) Signed-off-by: Peter Portante <peter.portante@redhat.com> Reviewed-on: http://review.gluster.org/4970 Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Reviewed-by: Luis Pabon <lpabon@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'ufo/setup.py')
-rw-r--r--ufo/setup.py57
1 files changed, 0 insertions, 57 deletions
diff --git a/ufo/setup.py b/ufo/setup.py
deleted file mode 100644
index a4831028..00000000
--- a/ufo/setup.py
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/usr/bin/python
-# Copyright (c) 2012 Red Hat, Inc.
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
-# implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-from setuptools import setup, find_packages
-
-from gluster.swift import __canonical_version__ as version
-
-
-name = 'gluster_swift_ufo'
-
-
-setup(
- name=name,
- version=version,
- description='Gluster Swift/UFO',
- license='Apache License (2.0)',
- author='Red Hat, Inc.',
- author_email='gluster-users@gluster.org',
- url='https://gluster.org/',
- packages=find_packages(exclude=['test', 'bin']),
- test_suite='nose.collector',
- classifiers=[
- 'Development Status :: 4 - Beta',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python :: 2.6',
- 'Environment :: No Input/Output (Daemon)',
- ],
- install_requires=[], # removed for better compat
- scripts=[
- 'bin/gluster-swift-gen-builders',
- ],
- entry_points={
- 'paste.app_factory': [
- 'proxy=gluster.swift.proxy.server:app_factory',
- 'object=gluster.swift.obj.server:app_factory',
- 'container=gluster.swift.container.server:app_factory',
- 'account=gluster.swift.account.server:app_factory',
- ],
- 'paste.filter_factory': [
- 'gluster=gluster.swift.common.middleware.gluster:filter_factory',
- ],
- },
- )