summaryrefslogtreecommitdiffstats
path: root/xlators/protocol/lib/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/protocol/lib/src/Makefile.am')
-rw-r--r--xlators/protocol/lib/src/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/xlators/protocol/lib/src/Makefile.am b/xlators/protocol/lib/src/Makefile.am
index 53131f6d..6e0b5c4e 100644
--- a/xlators/protocol/lib/src/Makefile.am
+++ b/xlators/protocol/lib/src/Makefile.am
@@ -1,15 +1,14 @@
-libgfproto_la_CFLAGS = -fPIC -Wall -g -shared -nostartfiles $(GF_CFLAGS) $(GF_DARWIN_LIBGLUSTERFS_CFLAGS)
+lib_LTLIBRARIES = libgfproto1.la
-libgfproto_la_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D__USE_FILE_OFFSET64 -D_GNU_SOURCE \
+libgfproto1_la_CFLAGS = -fPIC -Wall -g -shared -nostartfiles $(GF_CFLAGS) $(GF_DARWIN_LIBGLUSTERFS_CFLAGS)
+
+libgfproto1_la_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D__USE_FILE_OFFSET64 -D_GNU_SOURCE \
-D$(GF_HOST_OS) -DLIBDIR=\"$(libdir)/glusterfs/$(PACKAGE_VERSION)/auth\" \
-DTRANSPORTDIR=\"$(libdir)/glusterfs/$(PACKAGE_VERSION)/transport\" \
-I$(CONTRIBDIR)/rbtree -I$(top_srcdir)/libglusterfs/src/
-libgfproto_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-
-lib_LTLIBRARIES = libgfproto.la
-
+libgfproto1_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-libgfproto_la_SOURCES = transport.c authenticate.c protocol.c
+libgfproto1_la_SOURCES = authenticate.c
-noinst_HEADERS = transport.h protocol.h authenticate.h
+noinst_HEADERS = authenticate.h