summaryrefslogtreecommitdiffstats
path: root/api/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2013-09-30 09:05:14 +0200
committerAnand Avati <avati@redhat.com>2013-10-02 13:04:03 -0700
commitc499ef86a2dfd4e7727ce876b6cf18ba79c94fe5 (patch)
treecfe2a3ec9a71a8901f5e482a179caec56020a056 /api/Makefile.am
parenta66bf67965dddd9decd9210c3a530fdc85b6430c (diff)
gfapi.py: support dynamic loading of versioned libraries
Currently gfapi.py only loads libraries by filename ending in ".so". On an installed system without development packages, the <lib>.so filenames are not available. ctypes.util.find_library() can be used to detect the files dynamically. In addition to this, also fixing some minor indention errors and package the library into the Python site-packages path. Python applications and libraries can now access libgfapi through 'from glusterfs import gfapi'. Change-Id: I71e38dabd3ade5dcf24813bf2fc25cda91b571c6 BUG: 1005146 Signed-off-by: Niels de Vos <ndevos@redhat.com> Reviewed-on: http://review.gluster.org/5835 Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'api/Makefile.am')
-rw-r--r--api/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/api/Makefile.am b/api/Makefile.am
index af437a64d..f0ad1ee97 100644
--- a/api/Makefile.am
+++ b/api/Makefile.am
@@ -1 +1 @@
-SUBDIRS = src
+SUBDIRS = src examples